This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


UPASS Eligibility Issue September 1, 20:10 PT
Incident Report for UBC
Resolved
All eligible students should now be able to access TransLink to apply for their UPass. Confirm your eligibility at https://planning.ubc.ca/u-pass-faq#item-232. If any eligible students continue to experience issues, please contact the IT Service Centre - https://it.ubc.ca/got-question-about-it-products-and-support#helpdesk.
Posted Sep 02, 2024 - 12:30 PDT
Update
We are continuing to investigate the issue. The next update is scheduled for 22:30 PT.
Posted Sep 01, 2024 - 20:12 PDT
Investigating
We have received reports of students having difficulty confirming eligibility for UPASS. IT staff are investigating.
The next update will be at 20:30 PT.
Posted Sep 01, 2024 - 18:19 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan).