This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Sporadic eduroam WiFi Network Authentication Issues at UBC Medical Program Sites
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 12:58 PDT
Investigating
Users at various UBC Medical Program Sites connecting to the eduroam WiFi network may be experiencing sporadic authentication issues. UBC and PHSA technicians are investigating.
Posted Apr 29, 2024 - 15:34 PDT
This incident affected: Network - Wireless (Wireless - Hospitals).