This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Intermittent Workday Issues, September 4, 2024, 13:22 PT
Incident Report for UBC
Resolved
This issue has now been resolved.
Posted Sep 06, 2024 - 15:34 PDT
Update
Technicians continue to work with Workday to resolve the issue. Students may not see their payment reflected immediately in their Workday account. Their payment should be reflected in their account within 48 hours.
Posted Sep 05, 2024 - 14:20 PDT
Update
Technicians continue to work with Workday to resolve the issue. Students may not see their payment reflected immediately in their Workday account. Their payment should be reflected in their account within 48 hours.
Posted Sep 04, 2024 - 20:17 PDT
Update
UBC IT technicians continue to work with Workday to resolve the issue.

Students may not see their payment reflected immediately in their Workday account. Their payment should be reflected in their account within 48 hours.
Posted Sep 04, 2024 - 18:04 PDT
Identified
UBC IT technicians are working to resolve the issue.

Next update will be at 18:00 PDT
Posted Sep 04, 2024 - 16:26 PDT
Investigating
Some users are experiencing intermittent issues with Workday performance and noticing slowness. Workday is investigating the issue on their end. More information will be shared when an update is available.
Posted Sep 04, 2024 - 13:38 PDT
This incident affected: Workday.