This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


RESOLVED: Campus Network Issue June 12, 2021, 09:20PT
Incident Report for UBC
Resolved
Earlier today there was a network outage at the UBC campus starting at 09:22PT.

UBC IT Technicians acted quickly and were able to restore services by 10:03PT.
Posted Jun 12, 2021 - 10:50 PDT
This incident affected: Network - Campus (Network - Point Grey).