This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


RESOLVED: Okanagan campus wireless network disruption - Monday June 20, 2022 09:40-09:50 PT
Incident Report for UBC
Resolved
The wireless network experienced a disruption to service between approximately 09:40 and 09:50 this morning. Technicians were aware of the issue and resolved as of 09:50. We apologize for the disruption to service.
Posted Jun 20, 2022 - 10:28 PDT
This incident affected: Network - Wireless (Wireless - Okanagan).