This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


FASmail issue. Outlook profile not loading June 16, 2022 09:30 PT
Incident Report for UBC
Resolved
The issue has been resolved
Posted Jun 16, 2022 - 16:03 PDT
Monitoring
Some users may experience issue when starting Outlook. It got stuck when loading profile. The issue has been fixed by our email team. If you are experiencing the problem, please restart Outlook.
Posted Jun 16, 2022 - 10:16 PDT
This incident affected: Email Services (Faculty and Staff Email (FASmail)).