This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Koerner Pavilion Network Outage - September 10, 2021, 12:30 PT
Incident Report for UBC
Resolved
The network connectivity issues at the Koerner Pavilion have been resolved.
Posted Sep 13, 2021 - 09:13 PDT
Investigating
Some users are experiencing network connectivity issues at the Koerner Pavilion which could affect VOIP phones and the Internet.

UBC IT technicians are currently investigating the issue.

Our next update is scheduled to be at 13:30 PT
Posted Sep 10, 2021 - 12:47 PDT
This incident affected: Network - Campus (Network - Hospitals).