This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


FASmail delays - Oct 03, 2022 11:00
Incident Report for UBC
Resolved
The queued emails have been processed and there should no longer be any significant delays.
Posted Oct 03, 2022 - 11:45 PDT
Identified
Email delivery for the Faculty and Staff Email system (FASmail) is delayed due to unusually high load. Our team are aware of this issue and are working on mitigating it.
Posted Oct 03, 2022 - 11:11 PDT
This incident affected: Email Services (Faculty and Staff Email (FASmail)).