Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
A fix is in place and will be made available in Production on February 24, 2026. Users will be unable to download the Student Photo Roster as a PDF file in the FGST tool till deployment. We apologize for the inconvenience.
Posted Feb 18, 2026 - 10:04 PST
Identified
The root cause has been identified and that a fix is being tested, with deployment to production planned soon.
Posted Feb 13, 2026 - 14:43 PST
Investigating
Users are currently not able to export or download the Student Photo Roster as a PDF file in the Final Grade Submission tool. Technical teams are investigating the root cause and working on a resolution. More information will be posted when available.
Posted Feb 12, 2026 - 11:06 PST
This incident affected: Other (Other - Vancouver, Other - Okanagan).