This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Workday Intermittent Issue - December 5, 2022 8:00PT
Incident Report for UBC
Resolved
The Workday issue has been resolved. Workday will continue to monitor the service if any problems occur.
Posted Dec 05, 2022 - 12:30 PST
Update
Workday login and access issue has been resolved. Workday and ISC will continue to monitor the service for stabilization. Next update to follow at 12:30 PT.
Posted Dec 05, 2022 - 11:30 PST
Update
Workday issue seems to have been resolved, but will pend to see if service is stabilized. Next update will be followed up at 11:30PT.
Posted Dec 05, 2022 - 10:35 PST
Update
Users are experiencing login issues with Workday. Please note that these issues are intermittent. Workday is investigating the issue on their end and are working to resolve. Next Update will be followed up on around 10:30PT or earlier.
Posted Dec 05, 2022 - 09:30 PST
Update
We are continuing to investigate this issue.
Posted Dec 05, 2022 - 08:45 PST
Investigating
Currently, users are experiencing login issues with Workday. Please note that these issues are intermittent. Workday is investigating the issue on their end and are working to resolve. Please check back here for updates. Updates will be posted in an hour.
Posted Dec 05, 2022 - 08:28 PST
This incident affected: Workday.