This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Workday Login issues September 16, 2022 08.30 PT
Incident Report for UBC
Resolved
Workday is now available and users should be able to login in without any issues. This was a Workday issue which was quickly investigated and resolved by the Workday team.
Posted Sep 16, 2022 - 09:41 PDT
Update
We are continuing to investigate this issue.
Posted Sep 16, 2022 - 09:25 PDT
Investigating
Presently we are experiencing login issues for Workday. Workday has confirmed this issue on their end and are working to resolve. This message will be updated at 10.00 AM PT or when we have more information.
Posted Sep 16, 2022 - 08:42 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan) and Workday.