This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Performance Issue Impacting University Computer Management System (UCMS), July 31, 2025, 08:30 PT

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 08:02 PDT

Update

We are actively working with Microsoft to resolve the issue. At this time, a definitive ETA is not yet available.
Posted Jul 31, 2025 - 12:40 PDT

Investigating

At 21:00 PT on July 30, 2025, UBC IT identified a performance issue affecting Microsoft Endpoint Configuration Manager (MECM), which supports the University Computer Management System (UCMS). The issue has been escalated to vendor support, and both UBC IT technicians and the vendor are actively investigating and working to restore full service.

This outage is currently impacting all UBC IT– and Edge Admin–managed Windows endpoints (including faculty, staff, and shared desktops and laptops) in accessing endpoint management services such as patching and software deployments via Software Center. Please note that this outage does not impact users' ability to access or use their devices.

IT admins are advised not to use the MECM console at this time.

We will provide further updates as they become available. Thank you for your patience and understanding.
Posted Jul 31, 2025 - 09:01 PDT