Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
The fix for the attachment download and preview issue in Outlook on the Web continues to roll out. We expect the resolution to be fully complete by the vendor’s next scheduled update. Next update by: Wednesday, March 5, 2025 at 11:30 AM PST
Posted Mar 03, 2025 - 12:18 PST
Update
The fix has reached nearly all affected users, with additional ones being addressed throughout the weekend. Next update by: Monday 2:00 PM PST
Posted Feb 28, 2025 - 19:15 PST
Update
Most users impacted by the attachment download and preview issue in Outlook on the Web should now see it resolved, with the fix continuing to roll out. Next update by 13:30 PT.
Posted Feb 27, 2025 - 21:26 PST
Identified
Some users who have migrated to Exchange Online and use Outlook on the web (outlook.office.com) may have trouble downloading or previewing attachments. Microsoft is aware of the issue and a fix is being implemented. Next update: 5:30 PM PST
Posted Feb 27, 2025 - 12:32 PST
This incident affected: Email Services (Faculty and Staff Email (FASmail), UBC Student Email).