This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


EduCloud Server Management Portal Intermittent Performance Issues December 8, 2022 10:00 PT
Incident Report for UBC
Resolved
Management portal performance issues are intermittent and may increase length of provisioning related tasks. We are continuing to work with the vendor on further performance improvements. If you experience issues please report them to the EduCloud Server support team via the Service Now self service portal.
Posted Dec 09, 2022 - 16:22 PST
Investigating
We are currently experiencing intermittent performance issues with management portal functionality where tasks such as provisioning, changing power states or guest OS customization may take longer than expected. We are currently working on the resolution with the vendor.
Posted Dec 08, 2022 - 12:15 PST
This incident affected: EduCloud Server (Management Interface - https://bcnet.educloud.ubc.ca, Management Interface - https://dr.educloud.ubc.ca).