This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Course Registration Issues May 16, 2023, 02:30 PT
Incident Report for UBC
Resolved
The issue has been resolved and students can now register or drop courses normally now. The student registration service (Course Schedule) was intermittently impacted on Monday May 15 from 1:00 am to 9:30 am and Tuesday May 16 from 1:00 am to 8:00 am. Students were unable to add/drop courses during these times and students received an error while trying to save changes to their registration.
Posted May 16, 2023 - 09:57 PDT
Investigating
We are currently experiencing a technical issue that is affecting course registration. We are actively working on a solution and hope to have it resolved shortly. An update will be posted here once we are operational again.
Posted May 16, 2023 - 06:58 PDT
This incident affected: Student Service Centre.