This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Planon outage March 10, 2025 19:00 PT

Incident Report for UBC

Resolved

As of 19.30 PT, the issue has been resolved and Planon is available once again.
Posted Mar 10, 2025 - 20:29 PDT

Investigating

Planon is currently experiencing issues, and can display a blank page upon logging in. Teams are aware of this issue and actively working on it.
Posted Mar 10, 2025 - 19:15 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan).