This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Myphone - call forwarding malfunction January 20, 2022 10:46 PT
Incident Report for UBC
Resolved
Technicians were able to resolve the issue with setting up call forwarding using the myphone.ubc.ca website this evening at approximately 10pm.
Posted Jan 21, 2022 - 00:47 PST
Update
We are continuing to investigate this issue.
Posted Jan 20, 2022 - 11:40 PST
Update
We are continuing to investigate this issue.
Posted Jan 20, 2022 - 11:39 PST
Investigating
Please be advised that users of the myPhone service are currently not able to update call forwarding settings. Existing call forwarding settings are still being honoured and call forwarding itself is working. Technicians are currently investigating.
Posted Jan 20, 2022 - 11:13 PST
This incident affected: Other (Other - Vancouver).