This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Power Outage at Multiple UBCO Residence Buildings December 27, 2021 13:45 PT
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Dec 27, 2021 - 17:01 PST
Update
Power has been restored as of 16:30 PT. All buildings and networks are back online.
Posted Dec 27, 2021 - 17:00 PST
Update
Addition to the list of buildings without power:

Quonset
Portable N
Portable V
Plant Growth Facility
Posted Dec 27, 2021 - 15:25 PST
Update
Below is a list of buildings without power:

PBV
UHOUSE
KAL
NICOLA
PURCELL
CASS
LOWER CAS
MONASHEE
SIMI
UPPER CAS
DAYCARE
GEO EXCHANGE
VALHALLA
SKEENA
Posted Dec 27, 2021 - 14:06 PST
Investigating
We are currently investigating the issue and working to get power restored.
Posted Dec 27, 2021 - 13:47 PST
This incident affected: Other (Other - Okanagan).