Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Following up on the Lockdown Browser poor loading performance incident that occurred on March 5th, 2025, the vendor, Respondus, has provided a detailed updated on the root cause of the issue. It seems to have been caused by a bandwidth limit that had been reached on the elastic network interfaces attached to their application server instances. The full report of their analysis and fixes has been posted in their status page: https://status.respondus.com/incidents/tsbdny8mzkt8
Please contact LT.Hub@ubc.ca if you have any questions.
Posted Mar 10, 2025 - 10:09 PDT
Resolved
Based on our testing, the performance loading issues with Lockdown Browser in Canvas has been resolved. Please email LT.Hub@ubc.ca if you continue to experience issues with Lockdown Browser.
Posted Mar 05, 2025 - 16:43 PST
Investigating
We are currently seeing a degraded loading performance for Lockdown Browser in Canvas. We have reported this to the vendor, Respondus, and they are currently investigating on the issue. Users may see longer than usual times in loading Lockdown Browser in Canvas, or may receive a Stop Sign “unexpected error”. We will provide another update as soon as the problem is resolved. Please contact LT.Hub@ubc.ca if you have any questions.
Posted Mar 05, 2025 - 12:27 PST
This incident affected: Other (Other - Vancouver, Other - Okanagan).