This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


UBC Okanagan Network Outage, June 02, 2025

Incident Report for UBC

Resolved

Technicians conducted maintenance yesterday evening to resolve the problem and we have resumed regular network operations.
Posted Jun 04, 2025 - 11:26 PDT

Update

Network remains stable and technicians are continuing to monitor and work with our vendor to determine root cause.

Update: Technicians will be performing maintenance to correct the issue. A short disruption of internet services will occur between 21:00 - 21:30 PT affecting Internet access at UBCO. Internal campus systems and telephones will remain operational. Inter-campus network services, along with UBC Visitor and Eduroam wireless services will remain operational.

Thank you for your patience and understanding.

The next update will be provided at 22:00 PT.
Posted Jun 03, 2025 - 15:45 PDT

Update

The network has remained stable throughout the evening. Our teams continue to monitor the situation closely and work with our vendor support to resolve. While no further disruptions are expected, users may notice intermittent internet connectivity. The next update will be provided at 08:30 PT on June 3rd.
Posted Jun 02, 2025 - 21:23 PDT

Update

The network has remained stable throughout the afternoon. Our teams continue to monitor the situation closely. While no further disruptions are expected, users may notice intermittent internet connectivity.

Thank you for your patience and understanding.

Our next scheduled update will be at 21:30 PT.
Posted Jun 02, 2025 - 19:21 PDT

Update

The network has remained stable throughout the afternoon. Our teams continue to monitor the situation closely. While no further disruptions are expected, users may notice intermittent internet connectivity.

Thank you for your patience and understanding.

Our next scheduled update will be at 19:30 PT.
Posted Jun 02, 2025 - 11:03 PDT

Update

Earlier today, we experienced intermittent network connectivity issues affecting UBC Okanagan campus.

Our teams continue to monitor the situation closely. While no further disruptions are expected, users may notice intermittent internet connectivity.

Thank you for your patience and understanding.

Our next scheduled update will be at 14:00 PT.
Posted Jun 02, 2025 - 11:02 PDT

Monitoring

Outage has recovered.
Posted Jun 02, 2025 - 09:59 PDT

Investigating

UBC Okanagan is currently experiencing a network outage. Technicians are currently investigating the issue and will post an update as more information is available.
Posted Jun 02, 2025 - 09:30 PDT
This incident affected: Network - Campus (Network - Okanagan).