This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Microsoft Exchange Online Service Disruption March 1, 2025, 12:45 - 13:15 PT

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Mar 01, 2025 - 15:11 PST

Monitoring

Exchange Online service was down from approximately 12:45 – 13:40 PT. This was a global issue affecting not only UBC but other Microsoft 365 users. Microsoft was able to identify the cause of the issue and has reverted their change to restore service. Service was restored at approximately 13:40 PT. Microsoft and UBC IT are monitoring to confirm service recovery.
Posted Mar 01, 2025 - 13:51 PST

Investigating

Microsoft Exchange Online mailboxes are not working at this time. Only FASmail and Student Email mailboxes that have been migrated to M365 Exchange Online are affected. Users are experiencing connectivity issues with webmail, mobile and Outlook apps. This appears to be an issue affecting all M365 environments, including Hotmail and Outlook.com. Microsoft technicians are investigating.
Posted Mar 01, 2025 - 13:32 PST
This incident affected: Email Services (Faculty and Staff Email (FASmail), UBC Student Email).