Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
The authentication issues have been resolved. UBC IT technicians are closely monitoring services.
Posted Aug 11, 2026 - 14:09 PDT
Update
Further authentication issues have been identified and are impacting some services across campus. Users experiencing issues can clear their browser's cookies and cache, and try logging in again.
UBC IT technicians are continuing to investigate the issue.
Posted Aug 11, 2026 - 12:36 PDT
Monitoring
.
Posted Aug 11, 2026 - 12:30 PDT
Update
Authentication services have been restored. UBC IT technicians will continue to monitor services closely. The next update will be at 12:30pm
Posted Aug 11, 2026 - 10:37 PDT
Update
We are continuing to investigate this issue.
Posted Aug 11, 2026 - 10:34 PDT
Investigating
Users are currently experiencing authentication issue when logging in to UBC Services. The issue is being investigated.
Posted Aug 11, 2026 - 10:15 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan).