Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2024 - 19:00 PDT
Scheduled
On March 13, 2024, 19:00-23:00 PT, UBC IT will perform system maintenance on the UBC Faculty and Staff Email (FASmail) and the UBC Student Email service. No outage is anticipated during the maintenance window. However webmail users will see an updated Cisco Duo Multifactor Authentication window when logging in. For more information, see: https://ubc.service-now.com/kb_view.do?sysparm_article=KB0018724&ga=#geninfo
Posted Mar 12, 2024 - 15:24 PDT
This scheduled maintenance affected: Email Services (Faculty and Staff Email (FASmail), UBC Student Email) and Campus Wide Login (Multi-factor Authentication (MFA)).