Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Email services are restored. Some users may still be experiencing a slight delay in mail delivery. Email services will continue to be monitored as the service is fully restored.
Posted Sep 26, 2023 - 15:04 PDT
Update
UBC Student Email is also experiencing a service outage. Users of both FASmail and UBC Student Email will not be able to access email services during this time.
UBC IT technicians are currently investigating the issue and looking to restore access as soon as possible.
Our next update is scheduled to be at 15:00 PT.
Posted Sep 26, 2023 - 13:42 PDT
Update
We are continuing to investigate this issue.
Posted Sep 26, 2023 - 12:37 PDT
Investigating
We are currently experiencing a service outage with FASmail, which is affecting Outlook and Webmail. Users will not be able to access email services during this time.
UBC IT technicians are currently investigating the issue.
Posted Sep 26, 2023 - 12:30 PDT
This incident affected: Email Services (Faculty and Staff Email (FASmail)).