This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Authentication Issues Impacting Select UBC Services, 13:00 PT, Sunday July 20, 2025

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 13:12 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 05, 2025 - 09:31 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 05, 2025 - 09:29 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2025 - 08:29 PDT

Identified

UBC IT technicians have identified the issue and have restored all services; they will continue to monitor the services to ensure their stability.
Posted Jul 20, 2025 - 18:03 PDT

Update

UBC IT technicians are continuing to look into the issue and working on restoring all services.

Our next update will be at 18:00 PT.
Posted Jul 20, 2025 - 16:52 PDT

Update

UBC IT technicians are continuing to look into the issue and working on restoring all services.

Our next update will be at 17:00 PT.
Posted Jul 20, 2025 - 15:57 PDT

Investigating

As of 13:00 PT today users may have been experiencing authentication issues with the following services. UBC IT technicians are currently looking into the issue and working on restoring all services.

All CWL Account creation will be unavailable to:
Students, applicants, alumni
LLIS learners
Basic
Workers

Authentication to the following services will be unavailable:
Workday
Appian
Library (OpenAthens, Dryad, Meescan)
UBC Bookstore
LLIS Public/Staff portals
PrairieLearn (CPSC)
Faculty of Medicine (REAP)
Applicant Service Centre (ASC)
CWL Account Upgrader (CWLU)
DAF website
DeDupe website
PHUB-admin website
Science One
UNI CRM
UBC Student Housing and Community Services myAccount (including UBC Card)
Vidcruiter
UPass
UBC Elections
AMS Elections
Faculty of Medicine simIQ
Verify SP

Merging/Deduplication unavailable

Our next update will be at 16:00 PT.
Posted Jul 20, 2025 - 15:21 PDT
This incident affected: UBC Identity Broker (UBC Applicant & Student Federation (idb0), UBC SecureLink Federation (slid), UBC -- Identity Verification), Campus Wide Login (UBC Identity Provider), and Workday.