Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Maintenance for the Course Schedule Website (courses.students.ubc.ca) has been completed.
Posted Sep 05, 2024 - 17:30 PDT
Update
The Course Schedule website is available. In addition, Course Search functionality is now available. Teams continue to work to restore the Browse functionality. We will provide updates here as the full site becomes available.
Posted Jun 18, 2024 - 12:23 PDT
Update
The Course Schedule website courses.students.ubc.ca is unavailable.
Teams are working to restore the site. We will continue to provide updates here as the full site becomes available.
Posted Jun 18, 2024 - 10:56 PDT
Update
The Course Schedule website courses.students.ubc.ca has been partially restored and Standard Timetable information is available. Teams are continuing to work on the site. We will continue to provide updates here as the full site becomes available.
Posted Jun 04, 2024 - 13:06 PDT
Update
The Course Schedule Website courses.students.ubc.ca is undergoing maintenance and continues to experience issues. Teams are continuing to work on restoring the site. We will continue to provide updates here as the site becomes available.
Posted Jun 03, 2024 - 14:18 PDT
Update
The Course Schedule Website courses.ubc.ca has been partially restored and Standard Timetable Information is now available. Teams are continuing to work on the site. We will continue to provide updates here as the full site becomes available.
May 31, 2024, 17:10
Posted May 31, 2024 - 17:31 PDT
Investigating
The Course Schedule Website courses.students.ubc.ca is currently undergoing maintenance. Teams are working to restore this site. We will continue to provide updates here as this site becomes available.