This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Canvas files upload Outage September 22, 2023, 16:00 PT
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 16:43 PDT
Investigating
There is currently an upload file issue concerning Canvas and Canvas Catalog. Users are getting error messages when trying to upload a file or an image. We have contacted Instructure and we’ll keep you updated once we know more about it.

If you have any questions, please reach out at LT.hub@ubc.ca.
Posted Sep 22, 2023 - 16:29 PDT
This incident affected: Canvas.