This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Workday Login Issue - November 28, 2022 11:54 PT
Incident Report for UBC
Resolved
Update (14:48 PT)- Workday has resolved the issue as of 14:30 PM
Posted Nov 28, 2022 - 14:47 PST
Update
UPDATE Monday, November 28 2022 / 1:45 pm America/Los Angeles - 8:00 GMT

We are seeing that most tenants are once again available; however there are still some tenants that are having intermittent performance issues. We want to assure you that we are doing everything to resolve this issue. Our next update will be 2:45pm PT
Posted Nov 28, 2022 - 13:52 PST
Update
Update: This intermittent issue is still ongoing. Workday is investigating the problem and is doing everything to resolve at their end. Updates will be provided at 1:45pm PT, if not sooner.
Posted Nov 28, 2022 - 12:48 PST
Investigating
Currently, users are experiencing login issues with Workday. Please note that these issues are intermittent. Workday has confirmed this issue on their end and are working to resolve. Please check back here for updates.
Posted Nov 28, 2022 - 11:57 PST
This incident affected: Workday.