This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Canvas and Canvas Catalog – Service Disruption September 21, 2022 11:00AM
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 12:13 PDT
Monitoring
The vendor has identified the issue and applied a fix. Performance for Canvas (https://canvas.ubc.ca) and Canvas Catalog (http://ubccpe.instructure.com) has improved and we are continuing to monitor.
Posted Sep 21, 2022 - 11:50 PDT
Update
We are continuing to investigate this issue.
Posted Sep 21, 2022 - 11:33 PDT
Investigating
canvas.ubc.ca is currently unreachable. Users may be experiencing slowness or errors when accessing Canvas. We are currently investigating the issue with the vendor. Another update will be provided by 12:00 p.m. Pacific.
Posted Sep 21, 2022 - 11:30 PDT
This incident affected: Canvas.