This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Multiple UBC Websites Inaccessible, September 13, 2024, 09:00 PT
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 11:22 PDT
Investigating
Users may be experiencing intermittent issues with UBC IT- hosted websites.

IT Technicians are investigating the issue
Posted Sep 13, 2024 - 09:19 PDT
This incident affected: Other (Other - Vancouver).