This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


[Intermittent] CWL Login Issue April 18, 2025, 12:30 PT
Incident Report for UBC
Resolved
This incident has been resolved. We thank you for your patience as we worked to identify and address this issue.
Posted Apr 19, 2024 - 14:52 PDT
Update
UBC IT has addressed the intermittent issues with CWL logins and users are now able to log in to their services successfully. We are continuing to monitor the situation to ensure the service remains stable.
Posted Apr 18, 2024 - 20:01 PDT
Monitoring
UBC IT has addressed the intermittent issues with CWL logins and users are now able to log in to their services successfully. We are continuing to monitor the situation to ensure the service remains stable.
Posted Apr 18, 2024 - 20:01 PDT
Update
UBC IT has identified the issue and teams are continuing their work to restore access this evening.

The next update will be provided at 20:30 PT.
Posted Apr 18, 2024 - 18:15 PDT
Identified
UBC IT has identified the issue and teams are working to restore access this evening.

The next update will be at 18:30 PT.
Posted Apr 18, 2024 - 14:56 PDT
Update
UBC IT technicians are continuing to investigate this issue.

The next update will be provided at 14:45 PT.
Posted Apr 18, 2024 - 13:26 PDT
Investigating
We are currently experiencing intermittent issues with CWL logins.

Some users may experience intermittent issues logging in to the following services:

UBC Library
Appian Service
Canvas
UBC Housing
UBC Recreation Portal

UBC IT technicians are currently investigating the issue.
Posted Apr 18, 2024 - 12:51 PDT
This incident affected: Campus Wide Login (CWL Web Services).