This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Outlook Slowness Issue September 21, 2023, 14:30 PT

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Sep 28, 2023 - 01:52 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2023 - 14:30 PDT

Investigating

We are still currently experiencing intermittent issues with FASmail in Outlook.

Some users may experience Outlook performing slowly and intermittent delays.

UBC IT technicians are currently investigating the issue.
Posted Sep 21, 2023 - 10:56 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 20, 2023 - 11:56 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2023 - 11:55 PDT

Investigating

We are currently experiencing intermittent issues with FASmail in Outlook.

Some users may experience Outlook performing slowly and intermittent delays.

UBC IT technicians are currently investigating the issue.
Posted Sep 20, 2023 - 10:09 PDT
This incident affected: Email Services (Faculty and Staff Email (FASmail)).