Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2025 - 05:00 PST
Scheduled
The UBC Wireless Team will be performing network maintenance from February 19, 2025, 05:00 PT to 06:00 PT. During this time, there will be a brief outage to all WiFi services at the following locations;
Anthropology and Sociology Building Auditorium Annex Offices - A, B Morris and Helen Belkin Art Gallery Buchanan Building Buchanan Tower Cecil Green / Mary Bollart Chemistry Chemistry Physics Building A Henry Angus Building David Lam Management Research Centre Dorothy Somerset Studios Frederic Wood Theatre Geography Building Thea Koerner House Leon and Thea Koerner University Centre Hennings Building Hebb Building Sing Tao Building Walter C. Koerner Library Indian Residential School History and Dialogue Centre (IRSHDC) Irving K. Barber Learning Centre Ladner Clock Tower Frederic Lasserre Building West Mall Annex Mathematics Building Museum of Anthropology Music Building Old Administration Building
Posted Feb 18, 2025 - 20:19 PST
This scheduled maintenance affected: Other (Other - Vancouver) and Network - Wireless (Wireless - Point Grey, Wireless - Robson Square).