This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


SSC and SISC service degradation
Incident Report for UBC
Resolved
The SSC and SISC service degradation issue have been resolved.
Posted Jul 15, 2021 - 13:31 PDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2021 - 13:29 PDT
Investigating
SSC and SISC are currently experiencing a service degradation. We have received reports of problems with the Financial pages of the SSC and SISC. The teams are investigating the issue and do not have an ETA at this time.
Posted Jul 15, 2021 - 11:31 PDT
This incident affected: Student Service Centre.