This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


SITS/eVision is still undergoing maintenance on October 3, 2023 from 07:00 PT

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Oct 04, 2023 - 09:38 PDT

Investigating

Investigation is still on-going and we have no ETA yet.

During this period, SITS/eVision (including the Graduate Studies Admission System and Sauder Executive Education Registration System) service is expected to be not available.
Our apologies for the inconvenience.

For any questions or concerns, please contact sis.support@ubc.ca
Posted Oct 03, 2023 - 12:53 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan).