This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Workday login issues November 24, 2022 18.00 PT
Incident Report for UBC
Resolved
This incident has been resolved.
Posted Nov 24, 2022 - 18:16 PST
Update
We are continuing to investigate this issue.
Posted Nov 24, 2022 - 18:01 PST
Investigating
Users are unable to login to Workday. The team is investigating and will provide another update at 7 pm.
Posted Nov 24, 2022 - 18:01 PST
This incident affected: Workday.