This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


RESOLVED: Email Delivery Delays July 27, 2021 18:00 PT - July 28, 2021 02:00 PT
Incident Report for UBC
Resolved
Please be advised that some users may have experienced email delivery delays between July 27, 2021 18:00 PT to July 28, 2021 02:00 PT. Technicians have resolved the issue and queued messages are being delivered.”
Posted Jul 28, 2021 - 02:34 PDT
This incident affected: Email Services (Mail Relay).