This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Canvas and Canvas Catalog Service Disruption - November 22, 2025 09:40 a.m. PT

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Nov 23, 2024 - 09:33 PST

Monitoring

Canvas and Canvas Catalog experienced a service disruption between approximately 9:18 a.m. to 9:40 a.m. The website was not loading and some reported getting an error. The vendor implemented a fix and was able to resolve the issue. We apologize for the service disruption. If you have any questions, please contact the Learning Technology hub by emailing LT.hub@ubc.ca.
Posted Nov 22, 2024 - 09:51 PST
This incident affected: Canvas.