Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Duo has identified the issue and implemented a fix. Phone call and SMS are working with Duo MFA. UBC IT is continuing to monitor the situation.
Posted Feb 13, 2025 - 16:20 PST
Identified
The issue has been identified and are actively deploying a fix.
Posted Feb 13, 2025 - 12:30 PST
Investigating
There is currently an issue with the Duo cloud application, affecting UBC’s multi-factor authentication services. User may not be able to use phone call to pass the MFA prompt. SMS is intermittently unavailable.
If you are relying on phone call as your primary MFA factor, please try using SMS instead. Other MFA methods such as Duo Push, Passcodes, and Hardware Tokens are functional.
Self-service device management and Duo Admin are also unavailable.
Posted Feb 13, 2025 - 10:58 PST
This incident affected: Campus Wide Login (Multi-factor Authentication (MFA)).