Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
The Intermittent FASmail access issue has been resolved.
Posted May 05, 2025 - 18:08 PDT
Update
The service has been restored. UBC IT technicians continue to monitor for further issues.
The next update will be provided at 17:00 PT.
Posted May 05, 2025 - 15:49 PDT
Monitoring
Our team is continuing to work on the issue and services are being restored. Users can try to login to their FASmail via mail.ubc.ca and/or restart Outlook. UBC IT technicians continue to monitor the service.
The next update will be provided at 15:45 PT.
Posted May 05, 2025 - 15:07 PDT
Investigating
We are aware of intermittent issues affecting access to mail.ubc.ca for some users and administrators. Our technical team is actively investigating the cause and working to restore full access as quickly as possible
Posted May 05, 2025 - 14:28 PDT
This incident affected: Email Services (Faculty and Staff Email (FASmail)).