Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 10:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 18, 2025 - 15:28 PDT
Scheduled
The EduCloud Server environment for BCNET organizations in Kamloops will be undergoing scheduled network maintenance on March 22, 2025, 10:00-16:00 PT. BCNET EduCloud Server orgs in Kamloops may experience brief intermittent network outages from 10:00-12:00 PT. BCNET Kamloops org admins will not be able to manage NSX edge gateways, networks and load balancer settings from 12:00-16:00 PT.
Posted Mar 18, 2025 - 15:24 PDT
This scheduled maintenance affected: EduCloud Server (Management Interface - https://bcnet.educloud.ubc.ca) and Other (Other - Vancouver).