This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


University Data Centre UDC Integrating Two New UPS With Existing UPS Strings, June 4, 2022, 20:00 PT - June 5, 2022, 04:00 PT
Scheduled for Jun 4, 20:00 PDT  -  Jun 5, 04:00 PDT
Update
Two new UPS for the University Data Centre are being integrated with two existing UPS strings at this time. No service impact is expected.
Posted May 10, 2022 - 17:00 PDT
Scheduled
University Data Centre UDC Integrating Two New UPS With Existing UPS Strings, June 4, 2022, 20:00 PT - June 5, 2022, 04:00 PT
Posted May 10, 2022 - 15:28 PDT
This scheduled maintenance affects: Other (Other - Vancouver).