This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Okanagan Campus - Wireless network congestion - Tuesday September 19, 2023, 14:00 - ongoing
Incident Report for UBC
Resolved
The congestion issue has been resolved as of 14:30 PT. Technicians continue to monitor performance.
Posted Sep 19, 2023 - 16:02 PDT
Investigating
Okanagan campus wireless network is currently experiencing congestion. Some users may experience delays connecting to wireless (UBCSecure in particular). Technicians are aware and investigating.
Posted Sep 19, 2023 - 14:46 PDT
This incident affected: Network - Wireless (Wireless - Okanagan).