Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 03, 2023 - 08:00 PDT
Scheduled
Please be advised that on Oct 3 , 2023, 08:00 PT to 17:00 PT, Undergraduate Programs and Admissions (UPA) Salesforce pages and Go Global Application portals will be undergoing scheduled maintenance. Duration this time there may not be access for students to create an account, register for an event, submit their information on the Keep in touch form, submit a webform inquiry, or request a guide. The other sections of the UPA site such as Programs, Applying to UBC will not be affected. For Go Global application portal, applicants and partner universities may not be able to login to process Go Global applications.
Posted Sep 19, 2023 - 14:59 PDT
This scheduled maintenance affected: Other (Other - Vancouver, Other - Okanagan) and SalesForce.