This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Workday login issue March 17, 2025 11:50 PT

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 09:40 PDT

Monitoring

Technicians have identified the root cause. Users should see a return to normal Workday access. We will continue to monitor as access returns.
Posted Mar 17, 2025 - 13:44 PDT

Investigating

Due to a service interruption, users are currently unable to log into Workday. The issue is being investigated.
Posted Mar 17, 2025 - 11:53 PDT
This incident affected: Workday.