This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


[Koerner Library] Network is down <<March 16th, 2023, 08:35>> PT
Incident Report for UBC
Resolved
This incident has been resolved.
Thank you for your patience and understanding.
Posted Mar 16, 2023 - 09:22 PDT
Investigating
We are currently experiencing issues with Koerner Library network.

Some users may experience could not connect to network or VPN.

UBC IT technicians are currently investigating the issue.

Our next update is scheduled to be at <> PT.
Posted Mar 16, 2023 - 09:13 PDT