This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

To see what services are scheduled for maintenance,
view our Scheduled Outages Calendar

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


UBC Vancouver Power Grey Campus Power Outage
Incident Report for UBC
Resolved
We believe all services should now be restored. If you are still experiencing issues, please contact the IT Service Centre.
Posted Jul 06, 2022 - 12:56 PDT
Monitoring
Power has returned and systems are gradually returning. We are monitoring to ensure systems return as expected.
Posted Jul 06, 2022 - 10:28 PDT
Update
We are continuing to investigate this issue.
Posted Jul 06, 2022 - 10:08 PDT
Investigating
There is currently a widespread power outage on the UBC Vancouver Point Grey campus, which may impact some services.
Posted Jul 06, 2022 - 10:07 PDT
This incident affected: Other (Other - Vancouver).