This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Okanagan campus pay for print service disruption July 16, 2024 07:45 PT
Incident Report for UBC
Resolved
Pay for print services are functional as of 10:57 PT. Thank you for your patience as we worked to resolve the issue.
Posted Jul 16, 2024 - 11:07 PDT
Update
Technicians continue to work with the vendor to address the issue. The estimated time of restoration is not known. We will provide an update on progress at 11:30 PT.
Posted Jul 16, 2024 - 11:06 PDT
Update
Technicians are working with the vendor to correct the issue. At this time we do not have an estimated time for restoration of service. We will post an update at 10:30 PT to update progress.
Posted Jul 16, 2024 - 09:40 PDT
Investigating
The pay for print service is currently unavailable for faculty, staff and student use at the Okanagan campus. Technicians are aware and investigating the problem. An update will be posted at 09:00 PT.
Posted Jul 16, 2024 - 08:28 PDT
This incident affected: Other (Other - Okanagan).