This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Telus / BCNET Slow Connectivity Issue September 21, 2023, 15:15 PT
Incident Report for UBC
Resolved
BCNet has put in a fix that seems to have resolved the issue. The root cause is still unknown.
Posted Sep 22, 2023 - 12:07 PDT
Update
Telus and BCNET continue to investigate the root cause. BCNET will be making a proactive change tomorrow, September 22, 2023, 06:00 PT which should resolve the issue.
Posted Sep 21, 2023 - 18:52 PDT
Update
We are continuing to investigate the issue but the issue appears to be related to Telus service to BCNet, not a specific BCNET network issue.
Posted Sep 21, 2023 - 15:53 PDT
Investigating
UBC individuals using Telus service may be experiencing latency. The issue appears to be related to BCNET - Telus traffic issues. BCNET technicians are investigating.
Posted Sep 21, 2023 - 15:16 PDT
This incident affected: Network - Campus (Network - Hospitals, Network - Okanagan, Network - Point Grey, Network - Robson Square) and Other (Other - Vancouver, Other - Okanagan).