This site is currently under development  

Welcome to the UBC Information Technology Enterprise Services Status Page. Here you will find current information about the status of our enterprise services.

View our Scheduled Outages Calendar to see our planned maintenance windows,

For any questions or concerns, please contact the IT Service Centre.

You can also follow us on Twitter: @UBCIToutages


Threadz Service Disruption – September 26, 2023 08:45 PT
Incident Report for UBC
Resolved
Threadz service was restored at 4:45pm
Posted Sep 26, 2023 - 17:34 PDT
Update
We’re still working to resolve the incident. Next update will be at 3 PM.
Posted Sep 26, 2023 - 14:23 PDT
Update
Technicians are still investigating and will provide next update at 12pm
Posted Sep 26, 2023 - 10:08 PDT
Investigating
Threadz is returning errors when launched from Canvas. Technicians are investigating and will provide an update by 10am.
Posted Sep 26, 2023 - 08:50 PDT
This incident affected: Canvas.